Verified Commit b27c178e authored by Joey Vos's avatar Joey Vos 🤘

Pull glusterfs from it's PPA instead of old stuff from standard repo

parent a279b0f0
Pipeline #412 failed with stage
in 1 minute and 7 seconds
ARG RANCHER_HYPERKUBE_VERSION
FROM rancher/hyperkube:${RANCHER_HYPERKUBE_VERSION}
ARG GLUSTERFS_VERSION="7"
# Update GlusterFS Client
RUN DEBIAN_FRONTEND=noninteractive apt-get update -y \
RUN DEBIAN_FRONTEND=noninteractive apt-get -yy -q purge \
glusterfs-client \
&& { wget -O- https://download.gluster.org/pub/gluster/glusterfs/${GLUSTERFS_VERSION}/rsa.pub | apt-key add - } \
&& add-apt-repository -y ppa:gluster/glusterfs-${GLUSTERFS_VERSION} \
&& DEBIAN_FRONTEND=noninteractive apt-get update -y \
&& DEBIAN_FRONTEND=noninteractive apt-get -yy -q install \
glusterfs-client \
&& DEBIAN_FRONTEND=noninteractive apt-get autoremove -y \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment